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X-Figure Version 1.00 

X-Figure puzzles are similar to crosswords, except that the clues refer to numbers rather 
than to words. Just answer the clues and fill in the grid. At the simplest level this requires 
only straightforward arithmetic. Harder puzzles, however, cannot be started without some 
careful deduction. 

This program creates each new puzzle from scratch. There will always be a solution to the 
puzzle, although in some cases there will be more than one correct answer. 

X-Figure is shareware. Please distribute it as widely as possible using the original .ZIP file to 
keep the component files together. If you use the program regularly then your registration 
would be greatly appreciated and will encourage the author to fix bugs and add various 
improvements. 

This version of X-Figure had no known bugs at the time of release (June 1993). If you 
discover any problems or have any constructive suggestions then please let us know. Where 
possible and relevant, please save puzzles that give rise to bug reports. 

X-Figure is distributed and supported by SP Services, who can be contacted via electronic 
mail as sphipps@cix.compulink.co.uk or on Compuserve as 100016,1625. The author is Alan 
Saul. 



Shareware Registration 

For more details and an order form, please see the document ORDER.WRI that should have 
accompanied this software (the file is in Windows Write format). 

X-Figure is distributed as shareware. If you use it regularly then please register your 
appreciation and support future development by sending a cheque, payable to SP Services, 
for £10 to: 

SP Services 
PO Box 456 
Southampton 
SO9 7XG 
UK 

or telephone/fax (credit cards accepted): 
Tel: (0703) 550037 (International +44 703 550037) 
Fax: (0703) 322416 (+44 703 322416) 

Credit card instructions may also be sent by electronic mail to: 
sphipps@cix.compulink.co.uk or on Compuserve to 100016,1625 We 
accept Visa, Mastercard, American Express and all variants of these. Remember to include 
the credit card start and expiry dates. 

When registering, please state the name that you want to appear in the 'About Box' and 
other screens. This should be up to 30 characters in length. The number you will be given 
will only work with these details. 

US and Other Non-UK Users 
If you register using your credit card then we will debit your account in pounds sterling, and 
the credit card company will do any necessary currency conversion. As a special incentive, 
there are no extra shipping costs for non-UK orders! If you really cannot avoid paying in a 
currency other than pounds sterling, please add the equivalent of £5 sterling to the price 
you send to cover part of our currency exchange costs. 

What You Will Get 
You will be sent a certificate giving a registration code which will allow you to enter your 
personal details (specified with your order) into the program. 

You will not normally be sent a disc. If, however, you enclose an additional £5 handling 
charge, you will be sent the latest version of X-Figure and other shareware programs (please 
state disc format). 

When you receive the certificate, select the menu options Help, About X-Figure and then 
click on the Register button. Enter the details exactly as they appear on the certificate. 

If you upgrade to a later version of X-Figure, simply copy the new files over the existing 
ones. Your registration details will remain intact. 

See also Disclaimer and Agreement 



Disclaimer and Agreement 

Users of X-Figure must accept this disclaimer of warranty. If you do not accept this 
disclaimer, do not use the program. 

THE X-FIGURE PROGRAM IS SUPPLIED AS IS. THE AUTHOR DISCLAIMS ALL WARRANTIES, 
EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THE WARRANTIES OF 
MERCHANTABILITY AND OF FITNESS FOR ANY PURPOSE. THE AUTHOR ASSUMES NO LIABILITY
FOR DAMAGES, DIRECT OR CONSEQUENTIAL, WHICH MAY RESULT FROM THE USE OF X-
FIGURE, EVEN IF THE AUTHOR HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. 

THE LICENCE AGREEMENT AND WARRANTY SHALL BE CONSTRUED, INTERPRETED AND 
GOVERNED BY THE LAWS OF ENGLAND AND WALES. YOU MAY HAVE OTHER RIGHTS WHICH 
VARY FROM ONE STATE TO ANOTHER. 

Copyright for this software remains the property of: 
Alan Saul
12, Waxlow House
Hornbeam Road
Hayes
Middlesex
UB4 9EF
United Kingom

All contact should be made with SP Services in the first instance. 



Using the Mouse 

Before entering numbers with the mouse, the floating number pad must be displayed. If it is 
not then select Number Pad from the View menu. 

To enter a number in the grid, select the appropriate square (by clicking on it with the left 
button), and then click the appropriate digit on the number pad. 

If an entire clue is highlighted then the next digit in the answer will be selected. If, however, 
it is not clear whether you are answering an across clue or a down clue, the selection will not
move. 

There are a number of ways to indicate whether you are completing an across clue or a 
down clue: 
 Click on one of the direction buttons 

 or 
 

 Click on the text of the clue, rather than in the grid. 
 Select a square that only belongs to one clue. If you now select another square in the

same answer, that answer will stay selected. 

See also... 
Using the keyboard 
Entering notes 
Entering guesses 
Mouse buttons 



Mouse Buttons 

In common with normal Windows practice, most mouse actions within X-Figure use the left 
mouse button. Unless otherwise stated, references to 'clicking', in this help text, mean that 
the left button should be used. 

A few actions, however, may be performed by clicking or pointing with the right mouse 
button... 
 Entering notes from the Number Pad. 
 Deleting notes or answers using the 

 button on the Number Pad. 
 Hiding clues that are no longer of interest, by clicking on the text of the clue with the 

right button. 



Using the Keyboard 

To enter a number in the grid, simply type it in the normal way. Depending on the status of 
Numeric Keypad Notes on the Edit menu, the keys to the side of the main keyboard may 
have a different effect from those in the top row. 

The cursor keys can be used to select a different square. 

If an entire clue is highlighted then, on typing a digit, the next digit in the answer will be 
selected. If, however, it is not clear whether you are answering an across clue or a down 
clue, the selection will not move. 

In order to indicate in which direction you want to enter numbers: 
 Use Ctrl + one of the direction keys. 
 Move to a square that only belongs to one clue. If you now select another square in 

the same answer, that answer will stay selected. 

See also... 
Using the mouse 
Entering notes 
Entering guesses 



Verifying Your Answers 

There are two ways to verify what you have entered... 

Automatic Verification 
Enable Verify on the View menu. Now, as you enter numbers in the grid, the text of any 
relevant clues will change colour and have  or 
 displayed alongside them. The default colours are black for undecided , blue for correct , 

and red for incorrect . 

Verify may be turned on or off at any time. 

It is important to note that a blue or ticked clue only indicates that you have satisfied that 
particular clue (eg entered a square number for the clue `A perfect square'). The answer you
have given may yet make the rest of the puzzle impossible to complete! 

Reveal 
Enable Reveal on the View menu. This will show the known solution to the puzzle (it is 
possible for there to be more than one correct solution). Where you have already supplied 
the correct answer, the grid will be unchanged. Empty squares will have the answer shown. 

If you have given an answer which disagrees with the known solution, then the correct 
number will be shown in red (unless you have changed the colours) with your answer 
displayed in the top right corner of the square. 

See also... 
How answers are verified 
Changing the colours 



An undecided answer is one which has not yet been filled in, or whose clue refers to another 
which is itself undecided. 



A correct answer is one which matches the clue - whether or not it fits in with solution to the 
complete puzzle. See How answers are verified for examples of `correct' answers that are 
actually incorrect. 



An incorrect answer is one that fails to match the clue. 



Creating a New Puzzle 

To create a new puzzle, either select New Puzzle from the File menu or make a selection 
from the Puzzle menu. 

New Puzzle will create another puzzle of the same size and degree of difficulty as the current
one. The Puzzle menu allows you to alter these settings. 



Entering Notes 

While solving a puzzle, it is likely that you would want to make notes as you work things out.
It is possible to enter these in squares in place of answers. When you then enter an answer, 
it will hide any notes. 

Letters and puctuation characters can simply be typed in from the keyboard. Numbers can 
be entered in one of several ways... 
 From the keyboard using Ctrl+Number 
 From the keyboard using the separate numeric pad. Numeric Keypad Notes on 

the Edit menu will have to be enabled for this to work, and NumLock should be on. 
 Clicking on the Number Pad with the right mouse button. 



Changing the Colours 

The Colours option on the View menu displays a dialog allowing most colours to be 
changed. Note that some colours (such as the background of the clue listboxes) are tied to 
the settings given in the Windows control panel and cannot be altered from within X-Figure. 

Select an item in the list box and the button corresponding to its current colour will be 
depressed. To change it, click on the desired button. 

Rather than have separate foreround and background colours for each item, backgrounds of 
the grid squares are items in themselves. It is quite possible to make the foreground and 
background of some things the same, thus rendering them invisible. It is up to you to avoid 
doing this (unless, of course, you particularly want to make something disappear). 



How Answers are Verified 

For the purposes of verifying your answers and changing the colour of clues, your answer is 
matched against the logic of the clue, not the known solution. 

For example, consider the clues... 

Across 
1. A perfect square (2 digits) 
2. 1 across times two (2 digits) 

Entering any of 01, 04, 09, 16, 25, 36, 49, 64 or 81 will result in 1 across being displayed 
as correct. In fact 01, 04 and 09 are not allowable, since answers never start with zero, and 
64 and 81 are clearly impossible since the answer to 2 across would not then fit. 

Whatever you give as your answer to 1 across, even if you enter a non-square (for 
example 24), then 2 across will be shown as correct so long as you enter twice this value 
(in this case 48). 



Clue and Puzzle Types 

Puzzles differ in a number of ways which can be seen by selecting Custom from the Puzzle
menu. In addition to the size of the grid, there are three main groups of clue types... 

1. Conversion Factors 
These provide an easy starting point to the puzzle since they can always be answered 
without looking at any other clues. 

2. Cross References 
These link two or more clues, so that the answer to one is a function of the answer to 
another. 

3. Miscellaneous 
These are clues with more than one possible answer, of which the correct one will have to be
determined from looking at other answers that depend on this one. 

Simple puzzles always have some clues of type (1) to get you started. 

Quick puzzles are similar to simple ones, except that the grid is larger and conversion 
factors of 10 are avoided. 

Cryptic puzzles do not have any clues of type (1). Starting will always require a little 
thought. 

See also... 
Customising puzzles 
Conversion Factors 



Customise Level 

Selecting Custom from the Puzzle menu gives you the opportunity to choose the 
following... 

Clue Types 
To customise the level of difficulty, select the type of clues that you want to appear by 
checking the appropriate boxes. 

Provided that you allow X-Figure reasonable scope for generating puzzles then it will abide 
by your choices. If, however, you do not select enough clue types then some others may 
have to be used. 

For example, if you choose only metric conversion factors then these will be generated along
with clues of the type `1 across plus n' and possibly some others. On the other hand, a 
puzzle consisting entirely of anagrams is quite reasonable and, if you check just the 
anagrams box, that is what you will get. 

Basically, the rules are that in the Conversion Factor and Miscellaneous groups, clearing a 
checkbox means that that type of clue will definitely not appear. In the Cross Reference 
group it only makes it less likely. Checking a particular box is never a guarantee that the clue
type will be used in any particular puzzle, only that it may. 
Grid Size 
X-Figure has a number of predefined grid shapes of each size. Selecting a particular grid size
ensures that one of that size will be used. 

Times Tables 
This setting is in indication of the multiplication tables that are likely to be used for clues of 
type `1 across times n'. It does not affect the choice of conversion factors. 

See also... 
Conversion Factors 



Conversion Factors 

X-Figure knows about the following types of conversion factor... 

Metric 
These are all multiples of ten, such as centimetres to the metre, cc to the litre etc. 

Imperial 
British imperial measures. Please note that some other nationalities have their own versions 
of some of these measures which may use different conversion factors from the british ones.
I will happily internationalise X-Figure in this sense if, and only if, there is a demand. 

Time 
'Days in a week' etc. 

Miscellaneous 
Mostly alternative forms of numbers, such as `dozen', rather than true conversion factors. 



Menus 

File menu 
Edit menu 
View menu 
Puzzle menu 



The File Menu 
New Puzzle 
Retrieve... 
Save 
Save As... 
Exit 



New Puzzle 
Generate a new puzzle from scratch, at the same level as the current one. 



Retrieve 
Read a puzzle that was saved earlier 



Save 
Save the current puzzle, along with any answers or notes that you have entered. If you have 
not yet saved this puzzle, you will be prompted for a filename. 



Save As 
You will be asked to supply the name of a file, in which the current puzzle will be saved along
with all answers or notes that you have entered. 



Exit 
Exit the X-Figure program. Settings such as window position and colours will be saved - the 
current puzzle will not. 



The Edit Menu 
Enter Guesses 
Upgrade Guesses 
Remove Guesses 
Numeric Keypad Notes 



Enter Guesses 
With this menu option enabled, your answers will be shown in a different colour (normally 
yellow) to indicate that they are currently guesses. Such answers can then easily be 
removed, or converted to firm answers, using other options from this menu. 



Upgrade Guesses 
Convert all guesses to firm answers. 



Remove Guesses 
Delete all guesses from the grid. 



Numeric Keypad Notes 
With this enabled, the separate numeric pad on your keyboard can be used to enter notes. 
Note that NumLock should be on. 



The View Menu 
Verify & Reveal 
Show Hidden Clues 
Number Pad 
Status Bar 
Colours... 



Show Hidden Clues 
When you are no longer interested in a particular clue, you may click on the text to hide it. If
this menu option is selected, however, hidden clues are displayed, but greyed out. This 
allows you to retrieve a hidden clue by clicking on it again with the right button. 



Status Bar 
Use this to toggle the display of the status bar at the bottom of the screen. 



Hints 

An effective strategy, particularly for cryptic puzzles, is to look at each clue in turn and to 
drop notes into the grid about anything you can determine. Eventually notes from different 
clues will combine to yield the contents of a square. 
 Make notes about anything you know, however trivial, such as a multiple of two being

even. 
 Answers never start with zero. 
 Multiples of five are often the best clues to get you started. 
 Where one number is a multiple of another, the number of digits in each number 

provides a useful clue as to their most significant digits. 
 If the difference between two numbers is known, and also the last digit of one of the 

numbers, then the last digit of the other can be determined. 
 X-Figure never creates an impossible puzzle. Honest. 




